Home  •  Next Meeting  •  Contact Us  •  iCal  •  Check Email

MacGroup-Detroit    MacGroup iBBS    MacGroup iBBS  Hop To Forum Categories  Beginners SIG    Easts, Shoots & Leaves
Go
New
Find
Notify
Tools
Reply
  
Easts, Shoots & Leaves
 Login/Register
 
Jedi Council Member
Picture of Keith
posted
The one article in the Mac News that influenced me the most was written by one of our members from the distaff side (I'm sorry, I can recall her name), and it urged everyone to use proper punctuation when writing, particularly the dash. Since I'm a latecomer to Macs – having started out in DOS – I confess that I had been in the habit of using two consecutive hyphens to represent a dash, but not no more I ain't. I disciplined myself to start using the dash – even in place of its cousin the semicolon.

But lately, while reading messages I've sent in Mail 3.1, I noticed that all my dashes were missing, leaving all these run-on sentences. Did Mail eliminate all my dashes? No wonder no one answers my letters!

Must I go back to using two hyphens?
 
Posts: 668 | Location: Dearborn, MI | Registered: October 05, 2002Reply With QuoteReport This Post
Jedi Master
Picture of Chuck Reti
posted Hide Post
Keyboard equivalents;

hyphen - hyphen key
en dash – option+hyphen
em dash — option+shift+hyphen (no need for messy double--dash)
 
Posts: 1103 | Location: Detroit | Registered: June 11, 2002Reply With QuoteReport This Post
Jedi Council Member
Picture of Keith
posted Hide Post
Thanx, Chuck, but I know how to type the dash. The problem is that in Mail, the dash appears when I'm typing a message, but after it's been sent, the dashes don't appear in the message when it's displayed in the Sent folder.

If I receive a reply to the message, there are no dashes in my original message as it is displayed below the reply. If I forward the message and reinsert the missing dashes, they are then transformed into odd symbols such as –Â. I've only noticed this problem since installing Leonard and Mail 3.1.

Yes, in the Mail Preferences I have Rich Text selected as the Message Format.
 
Posts: 668 | Location: Dearborn, MI | Registered: October 05, 2002Reply With QuoteReport This Post
Jedi Master
Picture of Chuck Reti
posted Hide Post
What are your default Message and Plain Text fonts? I think the defaults in Tiger and earlier are Lucida Grande and Monaco respectively.
I'm keeping my distance from Leopard just now, so don't know what added options might exist in newest version of Mail. Wondering if there's some UTF or Unicode issue going on. I've never seen regular ASCII characters go missing. Just for fun, shoot me a mail sometime with said dashes and I'll see if they get sent OK. chuckr at mac dot com
 
Posts: 1103 | Location: Detroit | Registered: June 11, 2002Reply With QuoteReport This Post
Jedi Council Member
Picture of Keith
posted Hide Post
One hour and 20 min. on the phone with Apple Care today trying to solve this. I got as high up the chain as their Product Specialists in Sacramento. We were unable to duplicate the problem, but he had me trash the Preferences and Cache anyway.
 
Posts: 668 | Location: Dearborn, MI | Registered: October 05, 2002Reply With QuoteReport This Post
Jedi Council Member
Picture of Keith
posted Hide Post
On December 20, in yet another attempt to solve this annoying problem, I got through to an Apple Care Product Specialist ("wait time fifteen minutes or more" can mean infinitely more than fifteen minutes), and he had me trash the Mail cache and the Mail preferences. This caused all manner of havoc with my E-mail, as I then had to set everything up from scratch and find where my old messages had gone.

It seemed worth it, because the dash stopped disappearing from my sent messages – but only for about ten days. The problem came up again, but it's intermittent. Sometimes the dashes disappear upon sending, sometimes they don't. Sometimes they turn into bizarre characters such as —.

The by-the-book procedure for solving software problems is, of course, setting up a new user account and seeing if the problem persists in the new account. But since the problem is intermittent, I'd have to switch to this new account on a full-time basis, which means abandoning the continuity of my regular E-mail account.

I have thus given up all hope of solving this problem, and I'm now relearning to type two hyphens in the place of a dash.
 
Posts: 668 | Location: Dearborn, MI | Registered: October 05, 2002Reply With QuoteReport This Post
Poobah
Picture of Donna
posted Hide Post
Have you checked to see what your settings are in System Prefs: International?
 
Posts: 2284 | Location: Ann Arbor MI USA | Registered: October 22, 2002Reply With QuoteReport This Post
Guru
Picture of Jack Beckman
AIM: Online Status For jcbeckman@mac.com
posted Hide Post
Mail is probably using HTML for formatted mail. You have to jump through hoops for that to work:

http://www.cit.gu.edu.au/~anthony/wwwlab/iso/dashes.html


===
Professor Hubert Farnsworth: “Nothing is impossible. Not if you can imagine it. That’s what being a scientist is all about.”
Cubert J. Farnsworth: “No, that’s what being a magical elf is all about.”

 
Posts: 5470 | Location: Sterling Heights, Mi | Registered: January 25, 2004Reply With QuoteReport This Post
Jedi Council Member
Picture of Keith
posted Hide Post
Thanx, Donna! I think you nailed it! I sent out many E-mail messages today – each bearing numerous dashes – and all of the dashes remained when each message appeared in my Sent folder.

I was dubious of your suggestion at first, because (a.) if I had the wrong setting in International, surely the wrong characters would appear as I typed the message, and this problem would occur in other apps besides Mail; furthermore (b.) the American Flag is displayed in my Menu Bar, so obviously I had the USA selected in International.

I had mentioned that this problem had begun after I installed Leonard which automatically upgraded me to Mail 3.1. What makes troubleshooting so difficult is that, since my problem seemed to coincide with the upgrade, it seemed to imply a causal relationship. I had installed no other new software. What I had forgotten was that I read somewhere that you can display the calendar date in the Menu Bar along with the time. I forget how it's done, but this seemed like a good idea, so I made the tiny change and thought nothing of it.

Unbeknownst to me, doing so changed my Region to other. I changed it back to United States, and the date disappeared, but Mail now seems to keep its dashes.

My only question now is, in the Region drop-down, there is a choice between
United States
and
[n]United States (computer)[/b]
Which should I use?

United States (computer) comes with the warning that "This region is incompatible with some older applications . . . ." but it seems to work o.k. so far.
 
Posts: 668 | Location: Dearborn, MI | Registered: October 05, 2002Reply With QuoteReport This Post
Poobah
Picture of Donna
posted Hide Post
I did that menu-bar date/time fix also and it works fine, though it did take me some time to get it right. I am running 10.4.11 though. Not Leopard. In Prefs:International my language is set to English, my Region is Custom (you said yours was "Other") and my Input Menu tab shows On:checkmark, Name:Character Pallatte, Input Type: Pallatte, Script:Unicode.I don't remember changing anything in here for the date/time hack except Custom. If the Region drop-down setting you have now is working, I would not change it any further. And maybe you should avoid that date/time hack. Maybe it does not work that way in Leopard. I'm having a vague recollection that it said it was only for 10.4.
 
Posts: 2284 | Location: Ann Arbor MI USA | Registered: October 22, 2002Reply With QuoteReport This Post



Jedi Council Member
Picture of Keith
posted Hide Post
Groannn! I celebrated too early! My sent messages are turing dashes in to – again. My Region is still set at United States (Computer).

This only happens when I send an important message that I want to look perfect.
 
Posts: 668 | Location: Dearborn, MI | Registered: October 05, 2002Reply With QuoteReport This Post
  Powered by Social Strata  
 

MacGroup-Detroit    MacGroup iBBS    MacGroup iBBS  Hop To Forum Categories  Beginners SIG    Easts, Shoots & Leaves

© MacGroup-Detroit 2016

Next Meeting | Join Now | News | About MacGroup | Check Your Mail